Amazon LinuxでPHP5.6からPHP7にアップデートする

[Sponsored Links]

Amazon EC2(Amazon Linux)にインストールされているPHP5.6からPHP7.0にアップデートする。その手順を記載する。きれいに書くはずだったが、汚くなったので参考までに。

LAMP環境の構築はここを参考にして行っていて、PHP5.6がインストールされている。

1.PHP5.6の削除

yum removeでインストールされているPHP5.6を削除します。

1.$ sudo yum remove php *

削除後の確認

1.$ yum list installed | grep php

あれ、まだ残ってる。。
再度、削除します。

1.$ sudo yum remove php56-cli

php56-cliこれでphp56系の依存ファイルすべて削除完了する。

2.PHP7.0のインストール

PHP7.0をインストールする。

epelリポジトリ追加

1.$ sudo yum -y install epel-release

すでに最新バージョンがインストールされている。

remiリポジトリ追加

1.$ sudo wget http://rpms.famillecollet.com/enterprise/remi-release-6.rpm

remi-php70レポジトリ導入

1.$ sudo rpm -ivh remi-release-6.rpm

yumでインストール

1.$ sudo yum -y install --enablerepo=remi-php70 php php-mbstring php-pear php-mcrypt php-mysql
2....
3....
4.Error: httpd24-tools conflicts with httpd-tools-2.2.31-1.6.amzn1.x86_64
5.Error: httpd24 conflicts with httpd-2.2.31-1.6.amzn1.x86_64
6. You could try using --skip-broken to work around the problem
7. You could try running: rpm -Va --nofiles --nodigest

httpdでコンフリクトが発生した。
apache2.4をアンインストールする。

1.$ sudo yum remove httpd24-tools

再度apacheをインストールする。Apache2.2がインストールされる。

1.$ sudo yum install httpd

再度、remi-php70でインストールを試みる。

1.$ sudo yum -y install --enablerepo=remi-php70

これだとPHP5.3がインストールされる。。php70が有効になっていないよう。。

php70を使ってみる。

1.$ sudo yum install php70
2....
3....
4.Error: Package: php70-runtime-1.0-1.el6.remi.x86_64 (remi-safe)
5.           Requires: scl-utils

なにやらエラーになる。

[epel]でenabled=1に修正する。

1.$ sudo vim /etc/yum.repos.d/epel.repo

PHP70を再度使ってインストールする。

1.$ sudo yum install php70 php70-php-mbstring php70-php-pdo php70-php-mysql

あ、インストールできた。

動作確認

1.$ php -v
2.-bash: /usr/bin/php: No such file or directory

パスが通っていないのでパスを通す。

1.$ source /opt/remi/php70/enable

再度確認する。

1.$ php -v
2.PHP 7.0.3 (cli) (built: Feb  3 2016 10:50:08) ( NTS )
3.Copyright (c) 1997-2016 The PHP Group
4.Zend Engine v3.0.0, Copyright (c) 1998-2016 Zend Technologies

これでPHP7へアップデートできた。

  • このエントリーをはてなブックマークに追加
[Sponsored Links]

コメント

  1. […] – Qiita Amazon LinuxでPHP5.6からPHP7にアップデートする – owani.net#markdown Amazon Linux に php7.1 をインストール | // sakura […]